Capsule8 Docs
Capsule8 Docs
Help

Linux OS Compatibility Matrix

Below is the compatibility matrix showing whether the Capsule8 sensor supports different versions of Linux.

Linux Operating System Kernel Support
Amazon Linux 4.14 - 4.9 Yes
Amazon Linux 2 4.14 - 4.9 Yes
CentOS 6.9 2.6.32 Yes
CentOS 7.x 3.10.0-862+ Yes
CentOS 8.x 4.18 Yes
Container-Optimized OS 4.14 Yes
CoreOS 4.19.106 Yes
Debian 8.x (jessie) 3.16 Yes
Debian 9.x (stretch) 4.9 Yes
Debian 10.x (buster) 4.19 Yes
Fedora 25 - 31 4.8.6 - 5.5.8 Yes
RedHat RHEL 6.9 2.6.32 Yes
RedHat RHEL 7.x 3.10.0-862+ Yes
RedHat RHEL 8.x 4.18 Yes
Ubuntu 14.04 (Trusty Tahr) 3.13 - 4.4 Yes
Ubuntu 16.04 (Xenial Xerus) 4.15 - 4.4 Yes
Ubuntu 18.04 (Bionic Beaver) 4.15 - 5.0 Yes
Ubuntu 20.04 (Focal Fossa) 5.4 Yes

Container Runtime Compatibility Matrix

Below is the compatibility matrix showing whether the Capsule8 sensor and console supports different container runtimes.

Container Runtime Sensor Support Console Support
containerd Yes Yes
CRI-O Yes Yes
Docker Yes Yes
firecracker No Yes
frakti No Yes
Gvisor No Yes
kata No Yes
rkt No Yes